EMC-ARD1-001

Arduino Upgrade Kit

Arduino Included

Helpful instructional videos available at: mindsirobotics.com
When safety precautions are followed, your MINDS-i® system will provide years of enjoyment. Use care and good sense at all times when operating this product. Failure to use your system in a safe, sensible manner can result in injury or damage to property. You and you alone must insure that the instructions are carefully followed and all safety precautions are obeyed.

- Water can cause the electronics to short out and can cause permanent damage.
- Always turn on the transmitter before turning on the receiver.
- Fully extend the transmitter antenna before operating your vehicle.
- Before turning on your radio system, check to make sure that no one else is running on the same frequency.

**CHOKING HAZARD:** Do not allow children under age 3 or any individuals who have a tendency to place objects in their mouths to play with any part of the MINDS-i system, including, but not limited to: connectors, pieces, electronics, radio transmitters, wheels, tires. The system contains small parts which could accidentally be swallowed and cause suffocation.

- When the system is powered and/or in motion, keep fingers, face, tools, loose clothing, hair, and all other body parts away from gears, wheels, etc. Do no wear gloves while operating machinery. Even plastic parts can pinch, cut, or crush.
- The transmitter’s antenna could also cause injury if played with violently or pointed towards someone’s face.
- Never operate your MINDS-i® system on streets or in any areas where full-size vehicles are.
- Do not pick up your MINDS-i® system when it is in motion.
- Never charge, run or store your MINDS-i® system in a location subject to high temperatures, low temperatures or high humidity. Do not store in direct sunlight.
- To avoid electronic malfunction, do not allow the vehicle to become wet. Short circuits will produce a very strong electrical current. Should your MINDS-i® system become wet, stop using it immediately.

**WARNING!** Electrocuton Hazard. Do not use the materials provided for other than its intended purpose.

- Do not put it into fire.
- Always use recommended batteries. If improper batteries are used, they may become hot, leak and may rupture.
- Do not attempt to recharge non-rechargeable batteries.
- Only batteries of the same equivalent type as recommended are to be used. Do not mix old and new batteries.
- Exhausted batteries are to be removed from the system and replaced with new ones. Recycle all used batteries.
- Do not lick batteries. If battery appears to be leaking or has a crystalline deposit on the outside, dispose of it immediately (wear gloves when handling, preferably nitrile or other non-reactive material).
- Do not run a wire between battery terminals, as wire will get very hot, can be irreparably damaged or explode.
- Make sure the batteries are installed with the correct polarity as shown. Do not disassemble your batteries. Never allow them to become hot or to burn. To avoid short-circuits, avoid getting them wet. Do not short circuit batteries.
- If liquid from inside the batteries contacts your skin or clothes, wash them with water. If leaked battery fluid gets into your eyes, flush them immediately with cool water and seek medical attention. Do not rub eyes.
- Always wear safety glasses to protect your eyes. Note that normal glasses, while usually made of impact-resistant plastic, will not afford sufficient protection from shrapnel or flying debris.
- Always wear close-toed shoes to protect your feet from heavy or sharp objects, which might be dropped.
- If you have long hair, keep it tied back or under a hat to avoid it becoming caught in moving parts.
- The MINDS-i® system contains small parts. Do not ingest. Do not insert into any orifice (e.g. nostrils, ears, etc).
- The system contains metal parts. Cutting or bending can cause parts to break; resulting in sharp edges which can cut skin.
- Battery disposal. Do not throw batteries into the trash, especially rechargeable batteries. Contact your local waste disposal office for information on battery disposal. Batteries should be stored as directed by your local hazardous materials disposal office until pickup (usually in a hard sided waterproof, non-conductive container, e.g. a plastic bucket).

**WARNING! IMPORTANT! RESPONSIBLE ADULT SUPERVISION IS REQUIRED FOR CHILDREN UNDER THE AGE OF 14. THIS PRODUCT IS NOT DESIGNED FOR UNSUPERVISED USE BY CHILDREN YOUNGER THAN 14 YEARS OLD.**

All pictures descriptions and specifications found in this instruction manual are subject to change without notice. MINDS-i® maintains no responsibility for inadvertent errors in this manual. Visit www.mymindsi.com for the latest updates and information.
MINDS-i® is a high-performance Construction/RC/Robotics System, which is NOT intended for use on the public roads or congested areas where its operation may conflict with or disrupt pedestrian or vehicular traffic. Read all enclosed information before operating. Fully illustrated, step-by-step instructions describe adjustment, operation, and required maintenance procedures. MINDS-i® should not be operated in a crowd, or without adequate space. In an effort to continually upgrade our products, MINDS-i® reserves the right to make improvements and modifications to this system, which may not be reflected in the photographs and specifications printed on this box. PROPOSITION 65 WARNING: This product contains chemicals known to the State of California to cause cancer and/or birth defects or other reproductive harm.

Terms & Conditions: All orders placed with MINDS-i, Inc (phone, fax, mail, internet/web & email) constitute the acknowledgement and acceptance of all conditions listed below. All purchases remain the property of MINDS-i®, Inc until paid for in full. All orders shipped to a Washington State address must pay sales tax as required by the Washington State Department of Revenue. In the event that an order placed on our web-site does not calculate sales tax and the order is being shipped to a Washington State address, MINDS-i® will calculate the sales tax when the order is processed and call or email the customer with the new amount. All prices, materials, design, color, contents included with a product and product specifications are subject to change without notice. Some product images may be shown with optional items that are sold separately. Depending on the products ordered and the destination of the order, certain shipping services may not be available. MINDS-i® will not be responsible for pricing errors and may cancel the order. Orders will not be shipped until all Credit Card information is verified and matched. All other orders (check or money order) will not be shipped until payment has been received in full. All unpaid orders will be cancelled after 30 calendar days. All weights shown for products are used for shipping calculation only and may not reflect actual weight of the product.

Product Warranty: MINDS-i® warrants to the original buyer that our products are free from defects in materials and workmanship for a period of 120 days from the original date of purchase (original purchase receipt required). This warranty does not cover abuse, misuse, incorrect wiring, modifications, alterations, connector damage, wear and tear or robot competition damage. If the Product is determined to be defective within the warranty period, MINDS-i® or its authorized service provider will, at our sole option, repair or replace any defective parts free of charge, or refund the purchase price. What you must do: Return the Product in its original packaging or packaging affording equal protection, freight prepaid, with proof of purchase, to an authorized MINDS-i® service provider. You are responsible for all shipping charges. For more information, contact MINDS-i® at (509) 252-5767 or info@mymindsi.com.

Shipping Errors and Defective Products: Claims for shipping shortages, errors, or defective materials must be in writing and received by Innovation First within ten (10) days after receipt of shipment by buyer. Failure to make such claim within the stated period shall constitute an irrevocable acceptance of the goods and an admission that the goods fully comply with all the terms and conditions of the buyer’s order.
01

- 1 Beam (x1)
- 2 Transition (x2)
- 2 Lock (x2)
04

- 11 BEAM
- 2 TRANSITION
- 2 LOCK
- 4 ROTATE

05

- 14 BEAM
- 4 LOCK
DO NOT OVER TIGHTEN

- 4 x #4-40 x 1/2" SCREW
- 4 x #4-40 NUT

1 x ARDUINO UNO
1 x ARDUINO BASE PLATE
4 x CLEARANCE THREAD ADAPTER
1 x SENSOR SHIELD
FOR USE WITH:

LEAF SPRING SUSPENSION
4-LINK SUSPENSION

LADDER BAR SUSPENSION
FOR USE WITH:

HELPFUL INSTRUCTIONAL VIDEOS AVAILABLE AT: www.mymindsi.com

SUPER CRAWLER SUSPENSION
6x6 SUSPENSION
REFER TO ARDUINO USERS GUIDE FOR PROPER INSTALLATION AND SET-UP. USING THE WIRE TIES AND DOUBLE-SIDED TAPE PROVIDED, PLACE THE ELECTRONIC COMPONENTS ON THE FRAME SO THAT THEY ARE SECURE AND OUT OF THE WAY OF MOVING PARTS.

FOR TECHNICAL SUPPORT, E-MAIL US AT info@mymindsi.com OR CALL 509-252-5767
3-PIN WIRES
GROUND = BLACK
VOLTAGE = RED
SIGNAL = WHITE / YELLOW

4-PIN WIRES
GROUND = BLACK
VOLTAGE = RED
TX / SDA = WHITE
RX / SCL = YELLOW
Quick Start Guide; Autonomous Unmanned Vehicle AUV

Getting started:
1. Open the following link to access the file download. Once you have clicked the link corresponding to your operating system a pop-up window will appear asking you to “open” or “save” the file, save the file to “My Documents”.
Link: [http://arduino.cc/en/Main/Software](http://arduino.cc/en/Main/Software)

2. Plug in your board and wait for Windows to begin it's driver installation process. After a few moments, the process will fail, despite its best efforts.

3. Click on the Start Menu, and open up the Control Panel.

4. While in the Control Panel, navigate to System > Hardware > Device Manager.

5. Look under Ports (COM & LPT). You should see an open port named "Arduino UNO (COMxx)"

6. Right click on the "Arduino UNO (COmxx)" port and choose the "Update Driver Software" option.
7. Next, choose the "Browse my computer for Driver software" option.

8. Finally, navigate to and select the Uno's driver file, named "ArduinoUNO.inf", located in the "Drivers" folder of the Arduino Software download (not the "FTDI USB Drivers" subdirectory).

9. Windows will finish up the driver installation from there.

10. Once the Driver installation is complete open the Arduino program.

11. Next, click “File” > “Examples” > “0.MINDS-I” > “Projects” > “AUV___”
    Select “AUV4X4” or “AUV6X6” to match your chassis.

12. Once the file opens click the “UPLOAD” arrow, wait till it says “done uploading”

13. When the program finishes disconnect the USB cable from the robot and set it on the floor.

14. Flipping the ESC power switch to the on position will start the program running.

15. Watch as your robot drives around avoiding obstacles in its path.
Quick Start Guide; Manual Remote Control (RC Mode)

Getting started:
1. Open the following link to access the file download. Once you have clicked the link corresponding to your operating system a pop-up window will appear asking you to “open” or “save” the file, save the file to “My Documents”.  
   Link: [http://arduino.cc/en/Main/Software](http://arduino.cc/en/Main/Software)

2. Plug in your board and wait for Windows to begin it's driver installation process. After a few moments, the process will fail, despite its best efforts .

3. Click on the Start Menu, and open up the Control Panel.

4. While in the Control Panel, navigate to System > Hardware > Device Manager.

5. Look under Ports (COM & LPT). You should see an open port named "Arduino UNO (COMxx)"

6. Right click on the "Arduino UNO (COMxx)" port and choose the "Update Driver Software" option.
7. Next, choose the "Browse my computer for Driver software" option.

8. Finally, navigate to and select the Uno's driver file, named "ArduinoUNO.inf", located in the "Drivers" folder of the Arduino Software download (not the "FTDI USB Drivers" sub-directory).

9. Windows will finish up the driver installation from there.

10. Once the Driver installation is complete open the Arduino program.

11. Next, click “File” > “Examples” > “0.MINDS-I” > “Projects” > “SimpleRadioDrive”

12. Once the file opens click the “UPLOAD” arrow, wait till it says “done uploading”

13. When the program finishes disconnect the USB cable from the robot and set it on the floor.

14. Flipping the ESC power switch to the on position will start the program running.

15. Now you have full control of your robots Drive and Motion.
<table>
<thead>
<tr>
<th>PROBLEM</th>
<th>CAUSE</th>
<th>SOLUTION</th>
</tr>
</thead>
</table>
| **Wheels rotate backwards when forwards throttle is applied.** | 1) One or more of your differentials are installed upside down.  
2) The motor is spinning the wrong direction.  
3) The motor case was installed with the motor facing opposite of what the instructions show.  
4) The “throttle” switch on your remote control may be switched to reverse. | 1) Check the assembly instructions to make sure the differentials were installed correctly.  
2) Check that the wires from the ESC to the motor are connected properly.  
3) Check the assembly instructions to make sure the motor case was installed correctly.  
4) Flip the switch to normal. |
| **Front wheels rotate opposite of rear wheels when driving.** | 1) One of your differentials are installed upside down.  
1) Your steering trim is not centered.  
2) Your servo horn was not installed on the servo while it was centered. | 1) Check the assembly instructions for proper installation of the differentials.  
1) Center your steering trim.  
2) Remove the screw that retains the servo horn, then remove the servo horn. Turn the remote control on, center the trim on the remote, turn the vehicle on. Then reinstall the servo horn as the instructions show. |
| **Vehicle doesn’t drive in a straight line with the steering channel centered.** | 1) The linkages that connect your steering bar to the front wheel knuckles are not the proper length or do not match each other.  
3) The “Y”harness for four wheel steering is not centered. | 3) Remove the linkages and check that they are the length indicated in your instructions.  
4) Follow step 2 for front and rear servo, making sure when you center the trim on the remote to also center the trim on the “Y”harness. |
| **Servo does not operate when steering is applied.** | 1) Servo cable is plugged in upside down. | 1) Check that the cable is plugged in according to the wiring polarity guide. |
| **Servo steers only one direction or farther one way than the other.** | 1) Servo horn is not centered on the servo properly. | 2) Remove the screw that retains the servo horn, then remove the servo horn. Turn the remote control on, center the trim on the remote, turn the vehicle on. Then reinstall the servo horn as the instructions show. |
| **Vehicle has become under powered or sluggish.** | 1) Charge level of vehicle battery has dropped below useable level. | 1) Remove battery from vehicle and charge with the recommended charger. Always follow proper safety procedures when charging a battery. |
| **Vehicle stops unexpectedly or doesn’t respond to remote.** | 1) Charge level of remote control batteries have dropped below useable level.  
2) A wire may have come loose from the receiver. | 1) Check the remote control low battery indicator, if necessary replace or recharge batteries. Always follow proper safety procedures when charging a battery.  
2) Check that the wires are all properly plugged in and in good condition. |
| **Vehicle does not move forward or reverse when throttle is applied but audible tone comes from motor** | 1) Something has become bound up in the drivetrain. | 1) Check the drivetrain from motor to wheels for foreign objects and debris. Removing the drivelines that connect the motor case to the differential(s) then trying to spin the wheels will allow you to more easily locate the issue. |
| **Motor spins freely when throttle is applied but vehicle doesn’t move.** | 1) Gear mesh in motor case was not properly set.  
2) Pinion set screw was not Properly tightened. | 1) Check that the gear mesh was set according to the instructions. Gears should be about the thickness of this sheet of paper apart for proper mesh.  
2) Check that the pinion set screw was tightened according to the instructions. |
<table>
<thead>
<tr>
<th>PROBLEM</th>
<th>CAUSE</th>
<th>SOLUTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vehicle is not behaving as programmed.</td>
<td>1) Charge level of vehicle battery has dropped below useable level. 2) Inputs (sensors) or Outputs (servos, ESC, etc) are wired improperly. 3) Sensor is malfunctioning.</td>
<td>1) Remove battery from vehicle and charge with the recommended charger. Always follow proper safety procedures when charging a battery. 2) Check that each device connected to the Arduino Sensor Shield is plugged in properly. Both in polarity and into the proper port the program states. 2) Check #2. Connect Arduino to computer using USB cable, run the calibration program for each sensor on the vehicle. If the sensor value is not present, uncharacteristic or erratic the sensor may need to be replaced.</td>
</tr>
<tr>
<td>Serial port “COM_” not found.</td>
<td>1) The Arduino is not connected to the computer. 2) The proper serial port was not selected in the Arduino Program.</td>
<td>1) Connect the supplied USB cable and try again. 2) Disconnect, re-connect the USB Cable then go to Tools &gt; Serial Port then select the Arduino Uno.</td>
</tr>
<tr>
<td>Light on Ping))) sensor is not cycling.</td>
<td>1) The Ping))) sensor is not wired properly. 2) The Ping))) sensor is not connected to the proper port.</td>
<td>1) Check the wiring polarity guide for proper installation. 2) Check that the sensor is plugged into the port stated in the code.</td>
</tr>
<tr>
<td>QTI sensors not detecting line.</td>
<td>1) The QTI sensor is not wired properly. 2) The QTI sensor is not connected to the proper port.</td>
<td>1) Check the wiring polarity guide for proper installation. 2) Check that the sensor is plugged into the port stated in the code.</td>
</tr>
<tr>
<td>Power light on Arduino Sensor Shield doesn’t turn on when ESC is powered on.</td>
<td>1) One of the connections to the Sensor Shield is shorted. 2) No power source is connected to the Arduino.</td>
<td>1) Check that each device connected to the Arduino Sensor Shield is plugged in properly. Both in polarity and into the proper port the program states. If the problem persists disconnect one sensor at a time till the faulty connection (sensor, servo, ESC etc.) is found, then replace. 2) Check to make sure that it is either plugged into your computer with the USB cable or that you are using a charged battery and the ESC cable is properly connected.</td>
</tr>
</tbody>
</table>

For technical questions or to place an order:

Phone: (509) 252 - 5767
Fax: (509) 924 - 2219

Email us at:
info@mymindsi.com

Write to:
ATTN: MINDS-i Inc.
22819 East Appleway Avenue
Liberty Lake, Washington 99019

For the latest from MINDS-i visit:
mindsirobotics.com

For the most up to date version of the instructions go to:
mindsirobotics.com/instructions